Elevated Image API Errors
Incident Report for Imagizer Cloud
Postmortem

We experienced an unusually large spike in traffic from various sources in a short amount of time. The increased load caused a relatively small number of image requests on our east coast API to fail with a timeout. Our services autoscaled within minutes to provide the needed capacity to handle the load.

We increased the minimum number of image processing instances to handle any future traffic spikes of this magnitude.

Posted Jun 21, 2019 - 10:55 PDT

Resolved
This incident has been resolved.
Posted Jun 21, 2019 - 10:42 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 21, 2019 - 10:37 PDT
Investigating
We're experiencing an elevated level of Image API errors and are currently looking into the issue.
Posted Jun 21, 2019 - 10:34 PDT
This incident affected: Image API (us-east-1).