Elevated Image API Errors on us-east-1
Incident Report for Imagizer Cloud
Postmortem

We experienced an unusually large spike in traffic that overloaded one of our client's origin servers causing some incoming queries to be dropped with a 502 error. Unfortunately, this capacity issue spilled into the rest of our services as our application workers were busy handling the slow API queries.

We identified a weakness in our rate-limiting algorithm, which allowed the incident to occur. Furthermore, we deployed changes to our rate-limiting algorithm to mitigate any further related incidents.

Posted 7 days ago. Aug 13, 2019 - 17:31 PDT

Resolved
This incident has been resolved.
Posted 8 days ago. Aug 13, 2019 - 14:00 PDT
Investigating
We're experiencing an elevated level of Image API errors and are currently looking into the issue.
Posted 8 days ago. Aug 13, 2019 - 13:32 PDT
This incident affected: Image API (us-east-1).